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The GNU Image Manipulation Program is a GPL project from the Free Software Foundation  (for 
Windows and Linux) which many regard to be a drop-in replacement for Adobe Photoshop and 
similar. While the two are very similar, their focus is quite different. The GIMP is a painting 
program with a general application, while most proprietary versions concentrate on photographic 
effects and touchups.

This lesson is designed to form an introduction to the basics of GIMP use by walking you through 
the creation of a logo like the one at the top of the page. You'll start with a simple bit of non-fancy 
writing, and discover how the GIMPs power can be used to create some quite stunning effects.

Starting Off
Locate the GIMP in the top panel, under Applications > Graphics

(GIMP Welcome Screen)

Close the welcome screen �  it is the others that interest us right now. The long one to one side is the 
main control panel. It has a comprehensive array of tools and menus. I'll just be using the tool 
names, so you'll need to find them at first. Just point your mouse at a likely looking icon and let it 
sit for a bit �  a tooltip will pop up telling you what it's called and what it does. Those are the names 
I'll be using.

Like the welcome screen says, experimentation is encouraged. While I'll be showing you some of 
the moderately cool things this program can do, there are millions of possibilities. As soon as you 
like, explore the menus and the settings and see what they do.

If the GIMP has not already provided you with one, make a new session from the File menu. Accept 
the defaults. This will give you a blank white sheet about the right size for our purposes.

You're going to need some writing �  so select the text tool (see right) by left-clicking on it once. 
Then click on the blank workspace to start working.

A box will open up where you can type, and the result is displayed in the workspace. Don't worry if 
some of the letters go off the edge of the page, you can move them later.



When you have the writing you want, change the text Size using the 
main panel (right). The panel also allows you to change Font, colour, 
and use a variety of special effects. But for this tutorial, we'll keep 
things simple. The default font, black, is fine. Make the writing occupy 
about half-to-two-thirds the workspace.

Tip: in general, it is bet to work on images that are much bigger than 
you plan to use. Scaling down always produces better effects than 
scaling up.

� The GIMP�  logo in the title started out as the simple black and white 
image below..

One of the windows that opened up was called � Layers�  (if you don't 
see it, you can summon it from File > Dialogs > Layers in the main 
panel or the workspace window.)

You'll see a layer called � Background�  - click on this, then click on the 
trash can. Now the background goes into grey squares that indicate 
transparency.

Rt-click on the workspace to get a context menu, select save, and call 
the image � base.png� . The GIMP will ask if you want to export the 
image, say yes.

                                                           (Base Image for the Logo)

The base image used as an example here needed two text layers, created by using the text tool 
twice. The layers were moved to the right position with the move tool, then they were merged 
together by selecting the top text layer in the Layers dialog, rt-clicking on it, and selecting � merge 
down� .

I renamed the text layer by double-clicking it's name in the Layers dialog, writing the new name in, 
and pressing enter.

Polishing Off:
The workspace is called a canvass. You'll notice that the text layer sits in the middle of the canvass, 
looking untidy. The saved image will be a single layer the same size as the canvass, which is mostly 
empty space. The following steps will fix that.

Rt-click the workspace and select: layers > layer boundary size.
A dialog will appear, use this to add about 40 pixels to the existing layer, and make sure it is 
centered. Click OK. Now the layer isn't too tight on the text.



Rt-click the workspace and select image > canvas to layer size
Now the canvas is the same size as the text layer. Now it's tidy, you can save it.

Close the workspace window. Stage one is finished.

File Formats
In this example, you saved the image as a PNG (portable network graphic) file. This is a Free 
format which supports color correction and variable transparency while providing a reasonable file 
size. Which is why it was chosen. There are others, the main ones you'll meet are:

JPG: J-peg is a gratis format used mostly for photographs. Does not support any of the fancy 
effects that png boasts. However, large, complicated, image can be saved to smaller files using this 
format.  Jpegs are infamous for corrupting the fine detail of images leading many people to believe 
they have a blurry picture of something that isn't there, like pyramids on Mars.

GIF: is a non-free format (that's right: not gratis either) which supports transparency and animation. 
The main patents for this legacy format have recently expired. Replaced by PNG.

BMP: MS Bitmap format is a very old method of storing image data as � Raster Images� . The idea 
is that each pixel in the image gets described seperately in the file. This makes for very large files, 
so some form of compression is used to reduce the file size.

Resolutions and Image Quality
The display resolution determines the quality of the resulting picture. It is usually measured in dpi 
(dots per inch). For eg. My monitor has a 14 inch screen with a display size of 1024x768 pixels. 
This means my monitor is capable of displaying about 91dpi. (Pythagoras) maximum.

At this resolution, a 400x300px image is 4.4x3.3 inches in size. A full colour raster image of this 
size would be a 480kB file. A png at 80% compression would be 96kB (less for simple images).

Modern desktop printers typically use 300dpi for sharp images (some go to 1200dpi and higher for 
proffessional printing) so the above image would end up tiny indeed without some sort of scaling.

The GIMP saves images at your screen resolution by default. It is possible to save at a different 
resolution by first going to Image > Scale Image. If you double the dpi, you have to double the 
pixel  settings to get the same physical size. If you wanted that 400x300 image to still show 4.4x3.3 
inches but at 300dpi, then you'd need to change the pixel dimentions to 2000x1500.

Your screen will still only display 91dpi, (or whatever it is for your screen) but you'll be able to 
zoom in to see much finer detail.

There is always a balance between compression and scaling on one hand and image quality on the 
other. This is why it is best to work on images that are much larger than you need.

Now you have a base image, you can start messing with it. The next section walks through the 
creation of a simple logo. Much more complicated effects are also possible.



A Simple Logo
Use nautilus to browse to the place you saved the base image you had before. Find the icon for this 
image, and drag it over the GIMP control panel, and drop it. Wasn't that cool?

The effect we're going for is at the bottom-right of this page. Bottom-left shows what the layers 
dialog is like close to the finish. Right at the beginning it will have only one layer, probably called 
� Background� . I've renamed it to � The GIMP�  for this example.

In the layers dialog, duplicate the layer. (The tool is on the bottom line between the arrow and the 
anchor. As with all tools, point your mouse at it to get a hint.)

Rename the bottom copy � blur�  because that's what we are going to do with it.

Rt-click the workspace and select: filters > blur > gaussian blur. Set the blur radius to 10-12 
pixels to get the same effect I did. This will make one of the layers very fuzzy.

Back to layers �  select the top layer, then rt-click the workspace again. Select: colors > invert. This 
will make the top layer white �  now we can see it.

Back to layers �  duplicate the blur layer a few times to strengthen the effect.
Still in layers �  adjust the � Opacity�  of the top layer to give it a murky look (use the slider).

It is best to look at the image against the background you would normally use with it. In this case, I 
added a white layer �  the add layer tool is on the bottom row, far left.

The white layer can be moved up and down between the other layers using the arrows at the bottom 
of the layers dialog. Adjust the location of the white layer and see what happens.

(left: layer dialog, above: finished logo)



At this stage, the effect is that of a diffuse light right behing you, so there is a fuzzy shadow directly 
behind the white letters. The opacity setting gives the letters a milky-translucent look. 

You can change the light angle by changing the position of the top layer. Use the move tool in the 
control panel (looks like four arrows). Select the top layer in the layers dialog. Go to the workspace 
and drag the layer up and to the left just a tad.

And that's it �  remove all the layers you don't want to use. If you want to be able to use the logo on 
non-white backgrounds, then remove the white layer too. Merge all the visible layers, and save as a 
png file (to preserve the transparency).

Close the workspace.

The main lesson is in the use of layers. You should put different parts of whatever you're working 
on, on different layers. Switch between layers to work on the different parts. Merge the layers only 
at the end.

The menu most often used is where you rt-click the workspace. This is a quick way to reach all the 
special effects. You've seen blurring, you can see what the others do. Have fun.

Something to try �  make your base image white, with a white layer below it. Make sure the lower 
layer is selected and use the brush or airbrush tool to paint on it. Experiment with the different 
brush sizes and shapes.

If you make a mistake, you can use edit > undo to remove it. Use edit > undo history to remove 
lots of mistakes. If it's hopeless, remove the offending layer.

Special Effects and Colours
There were a lot of steps involved in making that logo, and that was a simple one. The GIMP also 
provides a collection of preconfigured scripts that enable very common effects with just a few steps. 
You'll find them in the context menu under Filters > Alpha to Logo.

All these images use four bytes to describe the colour each pixel. Each byte is also called a 
channel.Three for primary colors (Red, Blue and Green) and one called the � Alpha�  channel for 
transparency.

These scripts take images with a lot of transparency and do cool things with them. Like -

Drag the base image into the GIMP like before �  rt-click and select filters > alpha to logo > 
gradient-bevel. (The gradient-bevel dialog sometimes hides behind the workspace, just click the 
workspace title-bar to bring it forward.)

Keep the defaults for now �  click OK. (see next page.)



(left: gradient-bevel dialog)

(above: gradient-bevel effect;
                                                   right: gradient-bevel layers)

The effect is to make the logo look 3D, provide a drop-shadow, 
and a background.

The drop-shadow makes the logo � float�  above the page. If you 
move the Background layer up one, the logo will sit flush.

Duplicate the Background, and move the Background Copy to the 
top �  then click the triangle next to � normal�  on the � Mode� . 
You'll get a menu �  select � grain merge� .

Now you have the logo used in the title.

Of course, the color doesn't have to be white. In the main panel there is a color selector that looks 
like two boxes overlapping (below-left). The top box is for foreground and the bottom for 

background and they default to black on white.

The double-headed arrow top-left switches the colors over. The miniature copy 
bottom-left restores the black on white default when you're tired of messing with it.

Single-click the black box, and you get a dialog with lots of ways to change this 
(next page). There are 16777216 possible colours, and lots of ways to represent 

them. My favorite is the color-triangle shown next page.



This dialog alters the three colour channels, here called R, G, B. The main part of the selector is the 
wheel and triangle on the left. You select the color you want by clicking on the wheel.Then click on 
the triangle to select the exact shade of that color you want. The numerical representations show up 
to the right.

HSV is Hue, Saturation, and � Value�  and they are related to the RGB values. Try dragging your 
mouse around the wheel and see what happens to the sliders.

HTML Notation is used to set colors in web-pages. It uses a base-16 counting system called 
hexadecimal. The little TV with an eye-dropper on it is a tool which allows you to match an exact 
color from another picture.

Below that, there is a pallette consisting of commonly used colours, and colours you've used before. 
The curruntly selected and previous colours are displayed next to each other so you can fine-tune 
your selection. Here, I wanted a slightly different shade of teal.

Select a colour that appeals to you and click OK.

Back in the main panel, select the bucket-fill tool. Then, making sure the top layer is selected, apply 
the tool to the image. Now you have changed the colour.

Tools for manipulating color live under the color menu. You've already seen haw to invert a color 
from this menu. There is lots more, like �  

Delete the top layer to got the original grey logo 
back. Select the top layer. Rt-click the 
workspace, select color > colorize. Now you 
get a dialog that lets you set the HSV numbers.

Experiment moving the sliders around. This is 
similar to how old movies get colorized.



Here's a Challenge.

When using the bucket-fill tool, you are not restricted to colours, you can opt to fill with a pattern 
instead. The above logo uses a marble-tile pattern.

If you start with your base image, and merge it onto a white background, you'll be back to the 
black-on-white image you started with. Invert the colours so it's white on black, rt-click, select 
layers > transparency > color to alpha. Now you have a hole in a black background.

Invert the colors again, and apply the gradient bevel. Now you have a plaque ready to receive a 
pattern.

Another way of making impressions is with Filters > Map > Bump Map

Things to do: try out all the other filters. Have a look under Filters > Decore to get an old-photo 
look, complete with coffee stains. Try different blurring and distorts. Have a look at the HBCLUG 
wallpapers and see if you can figure out how they were done. Have a play, have fun, with ...
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